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Mozilla dissected

 

Abstract: 

After the long waiting time, Mozilla has already become an old animal.
They bread fast in the Mozilla family: the new generation (1.0.1 and 1.1)
has emerged and when you read this, 1.2 may just be born.
After many hours of testing and fiddling with the browser capabilities of
these youngsters, I describe my experiences below. 

In the first part I take a look at what’s available in the standard browser,
and then I review two of the many available add-ons. 

_________________ _________________ _________________

  

Installation

First off, you have to choose a version. 1.0.1 is actually the ’one and onlyTM’ Mozilla 1.0, but with a
few less bugs and some security issues fixed. If you prefer stability and compatibility, this is the one for
you. Otherwise you take version 1.1 or later - that’s where all the new functionality will show up. You
can track the development on the roadmap. 

The installation went very smoothly: just choose the Linux x86 Net Installer on the ’download’ page and



execute it (sometimes also available in other languages). The Net Installer (less than 100 kB) allows you
to choose which Mozilla components you like to have - if you take the ’Custom’ installation - and after
that it does its job. They just can’t make it simpler than this. 

By default, it installs in /usr/local/mozilla, but you can change the location. It’s possible to install
different Mozilla versions alongside each other - my /usr/bin/mozilla is just a simple shell script that
goes to the right dir and starts ’mozilla &’. The different versions are hard to distinguish from each
other - the differences that I noted are explained in the text below. You can check what version you are
running in the Help menu (Help=>About Mozilla). 

 
Figure 1: A simple installation process 

  

The fat boy

Mozilla is more than just a browser. In general, it is a platform for developers and for personal
communication (and the platform is in turn platform-independent :). There is the browser, the news/mail
client, the chat program, the html editor, JavaScript debugger, XML tools, the ’interface description
language’ XUL, libraries for downloading and installing applications and components and so on.

Never forget that in a lot of cases, you just don’t need stuff like ChatZilla (the IRC chat-client), the
Composer, the Mailer/newsreader or the adress book. If all you want is the browser, it’s a smart thing to
only install what you need (don’t forget to choose the ’Custom’ install in that case). 
As a simple, plain browser Mozilla has of course though competiton, Galeon for example. That one uses
the heart of Mozilla, (the rendering engine Gecko), but everything else is lighter and smaller. And also
Konqueror of KDE and Opera are still around, both worthy alternatives. 

If you choose to use Mozilla, you’ll have to accept the fact that it uses a lof of memory. I never found
that it felt ’slow’, and the startup-time also has also improved since the days before 1.0. But Mozilla
still likes a huge chunk of RAM, just like KDE by the way. Sad but true. For some older systems a RAM



upgrade is probably something you can consider. 

Just a remark: I often hear that ’the Linux desktop’ is really heavy compared to ’Windows’.
Agreed, KDE is not small, but you have to know what you’re comparing with! It can do
much more than -say- Windows98. In fact you should compare a recent Linux with a server
edition of WindowsXP (although... ;-). And then it shows: Linux does a great job. For older
systems you just have to seek out a lighter window manager / desktop - and your system will
be just as fast. Or just run your desktop on the heavy server in the network...
I also hear that the new Gnome needs less resources than its predecessor, which I find a very
good development.

A problem with ’alternative’ browsers is that some sites become unusable. Let it be clear that Mozilla is
not an ’alternative’ browser! There are very few sites that display errors, or nothing at all. And in that
case you can safely blame the site designer: Mozilla follows the standards almost perfectly, a very
important accomplishment. Congratulations to the developers! (and death to all the webmasters that
make sloppy sites on purpose!) 

This being said, let’s investigate whether the bells and whistles of the browser are of any use to us.   

The built-in bells...

The amount of included features and options is quite impressive. You get a good idea of the possibilities
by simply browsing the well-structured Preferences menu (Edit=>Preferences). Below we take a look
at many of these features.   

Tabbed browsing

Tabbed browsing is pretty well-known by now. It is a system that allows you to open multiple sites in a
single window. Each page has its onw ’tab’, on which you can click to ’activate’. It is mainly useful to
avoid having tens of Mozilla windows open at once. I use and like the tabs, but something bothers me:
why does every application has to invent yet another multiple document interface? Mozilla has such a
MDI, Kate the KDE editor, Opera and Galeon too... Each one with different concepts and different
keybindings. And then there is KDE itself, which groups windows of the same program under a single
button in the taskbar. Added together, this makes for a very confusing situation - but in the end I think
Mozilla has one of the better systems. Note that Konqueror from KDE 3.1 on will also support tabbed
browsing. 

Be sure to take a look at the options for tabbed browsing. I like to ’load tabs in the background’, and I
make sure that clicking the middle mouse button over a link opens a new tab. You can also make sure
that Control+Enter in the location bar opens a new tab. The best thing about the tabs are the
keybindings: Control+T opens a new empty tab, Control+Page Up and Control+Page Down change
between tabs, and Control+W closes the current one. And finally, just for convenience: Control+L
selects the text (URL) in the location bar.   

Bookmarks

The nice thing about the bookmarks (that come with an extensive management system) is the ability to



save multiple tabs under one bookmark (Bookmarks=>File Bookmark, and then choose ’File as group’).
In version 1.1 it can be done even faster: simpy choose Bookmarks=>Bookmark This Group of Tabs.
Very nice to open up a standard set of news sites for example, or to start surfing in the morning on the
pages you had open the day before. I only mis a little feature from Konqueror, where you can not only
Add to Bookmarks in the main Bookmarks menu, but also in its sub-menu’s. But don’t worry, so far I
can still live with it ;-).   

The sidebar

With F9 you turn on the sidebar (or, rather, turn it off :-). By clicking on its border, you can minimise it
to a couple of pixels width. What exactly would make the sidebar an advantage over a nice simple
website is unclear to me, although I suspect that Netscape uses them extensively in their browsers.
Inside it you can see tabs like ’search’, ’history’, ’what’s related’ and ’bookmarks’. 

Luckily anyone can make their own sidebars, and as a result many others are available. Some sites offer
a ’Netscape sidebar’ to track their news messages. I tried some that contain information about the tags of
the document formats HTML, XHTML and SVG (from zvon.org, who by the way do translations of
their pages the LF way). Installation of these sidebars is straightforward: click, choose ’OK’ and
everything will be all right, even when you’re not root. I personally would like to see a sidebar that
validates the current page with validator.W3.org. As lazy but well-meaning html writer I would really
welcome such a thing ;-)   

Privacy and security

This is a domain where Mozilla really shines. There are lots of feautures and possiblities regarding
cookie management, pop-up prevention... I recommend the options that only accept images and cookies
from the same webserver that provides the actual website you read. This can alreay stop or cripple quite
some Adv. networks. And there is more: you can view and remove individual cookies, or choose which
sites have persmission to ’cookie you’. Mozilla can also just ask permission for each single cookie, and
can remember your choices at that. Consider whether you need Java, JavaScript and cookies and turn off
as much as possible (by default Mozilla accepts all cookies and JavaScript has the right to open pop-ups
- turn it off asap!). 

Mozilla is also able to remember passwords and form data; this is something I turn of immediately.
(Yuk, I just don’t trust it.)   

Appearance

You can configure which buttons should be visible in the toolbar - ’Home’, ’Search’, ’Print’, ’Go’ and
’Bookmarks’ are not necessary in my view. This yields more space on the screen to display the URL.
Configurable in Edit=>Preferences=>Navigator. 

I do not really like the standard look, the ’Classic’ theme. It resembles the old & grey Netscape 4 and
makes it difficult to recognise the active tab. Compared with ’Classic’, I find the also supplied ’Modern’
theme a whole lot better. There are several other themes on the web, so everyone should be able to find
her favourite. For smaller displays I would recommend a ’tiny’ theme; I myself use the colourful and
small ’Orbit 3m’. 



small ’Orbit 3m’. 

 
Figure 2: Three themes: Classic, Modern and the small version of Orbit, ’Orbit 3m’. 

  

Smart browsing

Using smart browsing, you don’t always have to type URLs. In the first place, there are the ’internet
keywords’, actually a genuine Netscape.com thing. Certain keywords, such as ’seach’, ’quote’, ’help’
and ’goto’ are recognised when you type them in the location bar (like ’search linuxfocus’ of ’goto
linuxfocus’). Mozilla will then recognise the keywords, and opens a certain site with the right search
parameters. The only thing I like about this is that you can add your own keywords (using JavaScript)
for your favourite sites. Mozilla also has a setting for a standard search engine (by default netscape.com,
but google.com is also an option), which is also called when when you type single words in the location
bar. This last feauture was not present in some of the Mozilla versions I tested. All in all, I never got
used to using this ’internet keywords’ stuff, so I allways turn it off now. Maybe it’s more useful for
people who type very slowly :-) 
The other part of smart browsing is the ’location bar auto complete’, something that most current
browsers already have. I’m not lyrical about it :-)   

Type Ahead Find

Mozilla 1.2, of which I was only able to test the alpha version, contains the new feature called ’Type
Ahead Find’. This is a nice way to navigate without using the mouse: you just type a part of the link you
want to activate, and Mozilla will select it. Then an Enter will do to follow the link. For example: you
want to follow the first link below this line (Plugins and...), so you type plu+Enter and Mozilla will
take care of the rest. Once you know enough key bindings, it becomes very easy to navigate textually
without switching between the keyboard and the mouse. A nice extra feature is that you can also search
regular text by beginning the search with a /slash. Other things to remember: Escape cancels the current
search, and with (Shift+)F3 you can search forwards (or backwards). 

Figure 3: Type Ahead Find activates the right link after typing ’cast’ on the LinuxFocus.org main
page. 



 
  

... And the whistles

Aside from the standard features, you can get a lot of extras for the browser. Mozilla’s openness makes
it relatively simple to build extensions for it, and that has obviously paid off. 
There are the ’old-school’ plugins (see the article: Plugins and Mozilla 1.0), there are sidebars that start
to resemble complete applications, and then there are the other add-ons. By lack of time space we can
not describe them all, but there are ad blockers, surf anonymisers, a calendar, spellcheck, Jabber
messenger, a site downloader, ... Follows the links at the bottom: MozDev lists a lot of add-ons. The
following addons were tested by yours truly.   

Mother tongue

Mozilla speaks English of course, but that is not all. Intalling other languages is easy: clicking trough in
Edit=>Preferences=>Appearance=>Languages/Content will lead you to a page where all the
translations are listed. Clicking will do for the installation, at least if you have root rights and your
Mozilla version is not struggling (it once refused the translation, but kept on working fine as allways). In
some (or all?) languages you will see that the keyboard shortcuts are not translated, which is partly very
convenient and partly annoying. I was told that translating the shortcuts is a source of conflicts, and no
software exists for Mozilla to detect and to help solve these conflicts. Also be aware of the fact that not
all Mozilla builds have translations in your preferred language - you can check that in advance over
here. 

If you’re not a native English speaker, don’t forget to set up your favourite languages
(Navigator=>Languages), as used by some sites to automatically show you a translated version of their
pages (e.g. debian.org).   

Mouse gestures

One of the projects I stumbled upon on the MozDev.org site is called Optimoz. These people make two
of the nicer add-ons: ’Mouse gestures’ and ’RadialContext’. Mouse gestures (also known as MozGest) is
a system for controlling the computer with the mouse movements you make, not with buttons or menus.
By drawing a ’shape’ on the screen with a certain mouse button pressed down, you perform a specific
action.The Windows game Black&White also uses mouse gestures, just like the Opera browser in its
Windows version. You can view the list with defined gestures here at Optimoz. In addition, it is possible
to define your own gestures by editing the JavaScript code. 

 
Figure 3: Optimoz mouse gestures banner... 

The installation is smooth as always, provided you have root rights. I really enjoyed playing with mouse
gestures, but it never made me ’addicted’ to it. Most often clicking on buttons (or using keyboard
shortcurts) is just as fast, and sometimes a ’gesture’ was mis-interpreted by the software (i.e. I



performed it incorrect). But the possibility of creating your own gestures is very promising...   

RadialContext

The other part of Optimoz is ’RadialContext’. This is an implementation of a so-called ’pie menu’, a
kind of round menu system that appears around the cursor. By moving the mouse in 1 of the 4 (or 8)
directions you make a menu choice. It is kind of difficult to explain, but you can see it with your own
eyes if you are using mozilla: just surf to this page and see the look & feel in action. This is just a
demonstration: the actions you perform will have no effect until you install RadialContext yourself
(simple if you are root, as always). 

 
Figure 4: A view on RadialContext: the main menu, the tab menu and the image menu with help text. 

In the image you see the standard pie menu containing four functions in the directions up, down, left and
right. In between are four sub-menus which are accessed by moving the mouse pointer diagonally in the
corresponding direction without releasing the mouse button. Top-right, for example, there is the menu of
the tabs (shown in the middle part of the image). This sub-menu has functions to open or close a tab, and
to go to the next or previous one. This is pretty convenient to browse without touching the keyboard.
The other sub-menus deal with functions concerning ’window’, ’tasks’ and ’page’. In the ’normal’
menu, the four main functions serve to reload the page, to stop the loading, or to go back or forth in the
history. Used over an image, the four main directions get different functions, as you can see in the right
part of the image. There you can also see what happens when you don’t move the mouse for a while: a
little text explanation appears next to the menu choices. Used over a link, the menu changes once again,
this time providing functions to open the link in a new window or in a new tab, to copy the link or to
save its target. 
A nice overwiew of the menu contents is available here. 

Of course you can configure which mouse button RadialContext occupates; there is also a key available
to access the ’normal’ use of that mouse button as well. A little tip: do not use RadialContext together
with MozGest - that only confuses the browser. Possible improvements (according to me) could be: a
menu that does not move once it’s appeared, and showing the little help text by default (reducing the
useless waiting time). 

I notice that on my system mouse gestures are always turned off (easy to do in the preferences), and I
use the pie menu a lot. Often enought I don’t even wait for the menu to appear; I have learned to
memorise some of the actions and a ’wrong’ movement is very rare. When my hands are on the
keyboard I often use shortkeys, but if not I find nearly everything I need in the little round menu. I think
it’s an innovative and efficient system and I’m starting to really miss it in other browsers. Add to that the
fact that RadialContext is updated regularly and the verdict is clear: I recommend you to try it out
yourself sometime.   



Anfscd(*): Mozilla & presentations

(*) : And now for something completely different 

Presentation are performed in thousands of ways, and the software used can vary almost just as much.
Popular programs are, among others, OpenOffice, KPresenter and PDF- or PostScript readers. Ignoring
these last two, most programs use their own format (or that of Microsoft’s PowerPoint). As a result the
presentations are not readable on all systems, which is a big disadvantage when you can not use your
own computer. 

But actually, HTML fits really well for a solid presentation, certainly in combination with stylesheets.
This ensures that you can display on all available platforms, and if you can use Mozilla you can even do
it full-screen (under Linux full-screen only works on 1.1 and later). Just hit F11... 
It’s also possible to describe your presentation in a home-made XML language, and display it nicely
with CSS - of course this involves a risk with browsers whose XML or CSS support is not adequate. But
it certainly works in Mozilla - I’ve tested it. 

Are those tiny buttons still distracting your audience in fullscreen mode?
View=>Show/Hide=>Navigation Toolbar solves the problem. With RadialContext you no longer need
menus and buttons! You can still type an adress if you open the location bar beforehand with
Control+L. 
Right, now make sure that your page is smaller than the display and even the scrollbar on the side will
disappear...   

Links

galeon.sourceforge.net : Galeon, light browser based on Gecko, the Mozilla rendering engine.
opera.com : Opera, good little browser for Linux and others.
mozilla.org : official site of the Mozilla developers.
mozilla.org/releases/stable.html : here are the installation programs for the stable releases. Less
stable, newer releases can be found here.
mozilla.org/start/1.0/ : The default start page of Mozilla 1.0 has good information.
mozillazine.org : online magazine ’bout the moz.
mozdev.org : the site that is home to more than 70 Mozilla-related projects. Here is the impressive
list.
optimoz.mozdev.org : Optimoz, source of ’Mouse gestures’ and ’RadialContext’.
OperaShow : use Opera and stylesheets to give presentations.
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