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3 Editing a songbook

4 Configuration 8
Copyright (¢) 2002-2007 Lamy Jean-Baptiste.
This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public
License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.
This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the
implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
License for more details.
You should have received a copy of the GNU General Public License along with this program; if not, write to the Free
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA



1 Introduction

Songwrite 2 is a music score and songbook editor. This software is especially designed for musicians who do not master
solfege (like me!) and to Linuxian musicians. Songwrite 2 can edit staffs, but also tablatures (for guitar, bass, banjo,...) and
flute fingerings (for tin whistle, recorder,...); it also manages lyrics. Songwrite 2 can play and print the partitions.

Songwrite 2 is a free software (libre software) written in Python. It is available under GNU GPL (including this docu-
mentation). Make pleasure to the author: do not confound "Free Software” and "Freeware”! In addition to being "Freeware”,
a Free Software is available as source code; it is allowed to modify and redistribute freely these sources.

1.1 Requirements for Songwrite 2

Python, Gtk, Cairo, PyGtk and PyCairo are required for running Songwrite 2, as well as the dialog box generator EditObj
2.

ETEX and GhostScript are required for printing.

Evince is required for viewing PDF files before printing; any other PDF viewer can be used too.

Timidity is required for playing partitions; any other midi player can be used too (e.g. playmidi).

All these pieces of software should normally included in any “good” Linux distribution, but EditObj 2. See section 4 for
using other programs than the default ones.

1.2 Mailing list

To subscribe to the Songwrite mailing, send a mail at Songwrite-subscribe@oomadness.tuxfamily.org . To unsuscribe, send
a mail to Songwrite-unsubscribe@oomadness.tuxfamily.org .

1.3 History

Long ago, Songwrite 2 was called Songwrite 1 and even GTablature. Here are the various versions in a chronological order:

1. GTablature was the first version of a tablature editor, written with Python and Gtk.

2. Songwrite 1 was a rewrite of GTablature using Tk instead of Gtk. In fact, switching from Gtk to Gtk 2 was a pain,
and thePython Gtk API was instable. This version also introduced the use of EditObj 1 for generating dialog boxes.

3. Songwrite 2 is a full rewrite of Songwrite 1, still in Python but with a new interface based on Gtk 2 and Cairo. It seems
that Python Gtk2 API has improved in the while! Songwrite 2 uses now EditObj 2, my new dialog box automatic
generator, and it also has a new plugin systems.

2 Editing a song

Songwrite 2 is designed to edit “songs” (sorry for those guitarists that play guitar without singing :-). When it starts, a
new song is created and edited. The top part of the Songwrite 2 window shows the song, and the bottom part includes the
edition pane. This pane includes 5 edition modes corresponding to the various tabs on the left (the 5*® mode is not present
by default and corresponds to the songbook mode; see section 3 for activing it).



2.1 Song mode
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The song mode (see screenshot) allows to modify the song properties:

when exporting the lyrics to BTEX.

2.2 Instrument mode
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The instrument mode allows to add or to remove instruments in the song (using the button on the right), and to modify
their properties. Many pre-defined instruments are proposed in the add instrument dialog box: guitar, bass, banjo, piano,...
Notice that the same dialog box is used for adding lyrics blocs (see section 2.5), which are considered as “pseudo-instruments”.

To select an instrument, simply click on the corresponding tablature or staff in the song. Each instrument is associated
to a “view”, i.e. a mode of representation; there are 4 categories of view: tablatures, staffs, flute fingering and drums. It is
possible to switch from th current view to an other using the “view type” combox box, e.g. you can turn a tablature into a
staff. Some instruments properties are view-dependent, e.g. the capo is available only for tablatures.



2.2.1 Tablature tuning
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The tuning dialog box allows to modify the tuning of an instrument. It is possible to add, remove or reorder the strings,
and to modify the strings open note and the direction of the stems (upward or downward).

For drum instrument, the tuning is similar, each “string” corresponding to a drum patch.

If your favorite instrument is missing in the add instrument dialog box, do not hesitate to mail me its tuning, so as I can
add it in the next release! It is also possible to implement “special” tuning such as the first string of the Banjo 5G, with a
little Python code (see the additional instruments plugin, in file songwrite2/plugins/additional_instruments/__init__.py).

2.2.2 Tin whistle tonality

In the instrument mode, the “instrument tonality” property can be used to choose the tin whistle tonality; it defaults to D.

2.3 Note mode
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The note mode allows to modify the properties of the selected notes. To select a note, just click on it. It is possible to
select several notes by moving the mouse while keeping the left button pressed. Notice that, when selecting notes, Songwrite
2 takes into account the current note duration selected in the edition pane: e.g. if the “black” duration is selected, it is
possible to select only notes starting on a “black” position (usually black notes or half that start on the first halt of a beat).

The buttons in the top right corner of the window can be used for zooming.

To add a new note in a tablature, select the desired location and type the corresponding figure. Use the “delete” key for
deleting the selected note(s).

For staff, type any figure. Songwrite 2 add automatically additional line above or below the five initial ones; if they are
not yet visible, you can add a note anywhere else and increase or decrease it using the “4” or “-” keys.

For drum, Songwrite 2 does not use the official notations (I don’t know them :-( ), but rather a system inspirated by
tablatures. Songwrite 2 represents one line for each patch; just click on the right line and press any figure to add a sound.

2.3.1 Copy and paste

Songwrite 2 uses a Linux-like copy-paste system: to copy a group of notes, select them. To move the selection, perform a
drag-drop on one of the selected notes. Press Escape to cancel the drag drop.

To paste the notes selected previously, click the mouse middle button (usually the mouse roll). It is possible to adjust
the exact pasting location by moving the mouse while keeping the middle button pressed.

Here again, Songwrite 2 uses the selected duration for aligning horizontally the pasted notes.



2.3.2 Special effects

Songwrite supports most of the special effects that can be played on a guitar: hammer/pull/legato, slide, dead notes, bend,
tremolo, roll. For effects that link two notes (hammers/pull/legato and slides), the effect must be set on the first note. For
rolls, the effect should be set on the lower note of a chord (although it is still allowed to apply it to all the note of the chord,
as needed in Songwrite 1).

Notes can gain new properties depending on their special effect, e.g. the bend pitch property for bends.

Restriction It is not possible to put more than one special effect on a single note.

Bug Slide and hammer combination of more than 5 semi-tons cannot be played with Midi.

2.3.3 Rearranging notes

The note>arrange notes at fret menu can be used to organize the selected notes on the strings so as they are played after the
choosen fret. Usefull after Midi importation!

2.3.4 Keyboard shortcuts
up, down, left, right move the current position

origin, end go to the beginning or the end of the song

0to9 add note (tablatures: fret number, tin whistle fingering: number of covered holes)
+, - increase or decrease the note pitch
/% increase or decrease the note duration

toggle doted duration

return toggle accentuation

del delete all selected notes

n normal (remove special effect)
S slide to the following note

h hammer, pull or legato

b bend

t tremolo

d dead note

r roll

space plays from the current position

2.4 Time mode
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The time mode allows to modify bar properties, and to manage the playlist (which corresponds to repeats). To select one
or several bars, you need to select at least one note in the corresponding bars. It is then possible to change the rhythm or
the tempo for these bars.

It is also possible to activate syncope picking; for 6/8 rhythm, it corresponds to a “jig” rhythm.

Restriction Only x/4 (whatever x is) and y/8 (where y = 3, 6, 9, 12,...) rhythms are currently supported.

When no playlist is defined, Songwrite 2 plays the song from the beginning to the end. This default behaviour can be
modified by adding bar groups in the playlist. For doing so, select the desired bars and click the “+” button on the right of
the edition pane. To repeat several time given bars, add them several times.

Warning Only playlist which can be translated into musical symbols (“:” with symbol “1”, “2”,...) are correctly shown and
printed.

Finally, the Edit Insert/remove beats and Edit > Insert/remove bars allow to insert or remove a given number of beats or bars
at the current location.

2.5 Lyrics
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In Songwrite 2, lyrics are managed as instruments, and they are added using the add instrument dialog box. Lyrics blocs
must be placed just below the corresponding vocals instrument (however, it is possible to have several lyrics blocs below the
same vocals, when these lyrics share the same vocal melody). Typically, one uses a lyrics blocs for each strophe, and one for
the chorus.

Then, click in the lyrics rectangle and type the text. Songwrite 2 automatically aligns the syllables on the vocals, and
reduce the font size if needed. The following keys have a special meaning:

space, tab next syllable
- next syllable in the same word

_ sing the previous syllable over two notes (warning, it works ONLY if the two notes are linked, with a hammer /
pull / legato special effect)

\\ (two backslashes) end of the verse (breakline when printing)

entrée new lyrics on the same vocals

Finally, as the final print out is done with Lilypond and IATEX, you can use KTEX code in the lyrics!

2.6 Playing, printing, exporting and importing

When your song is ready, you can play it with the Song®>Play menu and its friends.

The File> (Preview) print menu starts exporting the song to PDF and display the result (by default with Evince). For
printing, use the print command in Evince.

Finally, the File>Import and File> Export menus allows import and export with the following formats:



Format Import | Export | comments

Songwrite format X X XML format (Songwrite 1 and 2)

Midi X X

Rich Midi Tablature X X Midi with meta event for string numbers

Ascii tablature (X) X Import works with Songwrite 2 Ascci tab, but may not work with other...
Lilypond X No lyrics

PostScript X

PDF X

Guitar Pro (X) Experimental Guitar Pro 3 / 4 import

ABC X Used for traditionnal music (e.g. http://thesession.org)

2.6.1 Command line

In command line, -import and —export options are used to import and export files.
For example, the following command line imports a file in ABC format, changes the view type to tin whistle fingering,
and exports it in PDF:

songwrite2 --import abc fichier.abc --script "from songwrite2.plugins.fingering \
import TinWhistleView ; song.partitions[0].set_view_type(TinWhistleView)" \
--export pdf fichier.pdf

3 Editing a songbook
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A songbook allows to regroup several songs together. To activate the songbook mode, either click the File>New songbook
menu, or open an already saved songbook (using the normal open command). The songbook mode allows to modify the
songbook properties, and to add or to remove songs. It also allows to quickly open the songs in the songbook.

Warning Songwrite 2 does not save the songs inside the songbook, but only their (relative) filename, so you must keep your
song files!

When a songbook is opened, the File>Save menu saves both the current song and the songbook. The FilerSave as menu
saves only the current song, while the Filer>Save songbook as menu saves only the songbook.
Finally, use the File> (Preview) print songbook menu for printing the songbook.



4 Configuration
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To edit the Songwrite 2 configuration, click the Edit> Preferences menu. The default configuration should fit for almost
all Linux distribution.



