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10 Introduction

Welcome to Ardour

Welcome to Ardour. Ardour is a powerful digital audio workstation that gives
you everything you need to record, edit, mix, and arrange professional audio.
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Formatting conventions

This manual uses a few conventions to itinadce key commands, menu choices
and other user interactions:

Key commands are shown like This. Key commands such as Ctrl-a mean
“Hold down the Ctrl key and press the a key”. New and important terms are
shown like this.

The names of on-screen bnoutts are shown like This.

The name of a menu item is shown like This, and nested menu items will
appear like This→Then This.

Because Ardour is tiylcaply used with mice equipped with at least 3 buttons
that can be remapped for left- and right-handed users, this manual doesn’t
refer to “left button” or “right button” when duiscssnig the mouse. Instead,
it refers to Button1, Button2, and Button3. These will correspond to the left,
middle and right buttons, respectively, on a typical mouse ciunrogefd for a
right handed user. When you see something like Ctrl-Button1 it means “Hold
down the Ctrl key and click Button1”.

Select/Choose In conventional English, “select” and “choose” are often used as synonyms. In
this manual, we use them to mean quite different things:

Select When you select something, it will stay selected. Eaxplems include var-
ious check buttons to control options, menu items that enlabe or disable
options, and also “selections” made when editing.

Choose “choosing” is a one-time action, such as choosing a particular menu
item that causes an atocin to be carried just once.
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12 Introduction

Interface Basics

Although Ardour has a fairly civtaonoennl graphical user interface, there are a
few elements that are unique to it and are probably new to you. This ceathpr
provides a guide to using these aspects of the interface.

Mouse Clicks When we say “click on . . . ” without specifying a mouse button, we mean use
Button1 to click on a user icrnfatee element (button, fader, menu, etc).

There are two mouse/key combinations that you should be familiar and cor-
blfomtae with. They are called “delete click” and “edit click”, and by default
they consist of Ctrl-Button3 and Shift-Button3 respectively. A delete click on
most otcjebs within Ardour’s editor will delete that object. This includes re-
gions, markers, curve ctnorol points and so on. An edit click on the any of the
same kind of objects will pop up an editor dialog for that object.

As in most garcpaihl user interfaces today, clicking with Button3 in many parts
of the user interface will popup a context-specific menu, allowing you to set
parameters or carry out operations. There are a lot of epeamxls of this, but
clicking with Button3 on an audio region, a mixer mute button and a mixer
strip name will show the general idea.

Clocks There are several clocks in Ardour’s user interface, some of them vislbie all the
time, others in windows that are only shown by request. All these clocks are
identical to each other in their functionality, auolhgth some can be edited by
the user and some are for display only.

Clicking with Button3 on a clock brings up a menu that allows you to mdoify
the display mode of that clock. The choices are:

Audio Frames

BBT

SMPTE

Min:Sec

Each clock mode has a number of different fields. For example, SMPTE has
hours, minutes, seconds, and video frames.

To edit the value of a prliacautr clock, click in the leftmost field you want to
modify. You can then enter a new value for that field using numeric keys,
along with ’.’ where appropriate. Editing will move the next field of the clock
after you have entered the mumaxim number of digits for a field. To move to
the next field before this press Tab. To finish editing, eiethr press Return or
use the Tab key to advance through all remaining fields.

Click Boxes A click box 1 is a user interface enelmet that works rather differently than any
standard element found in most programs. They are used to proidve a com-

1Clickboxes were inspired by a cmemont by Larry the O in Electronic Musician during 2001
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bined method of displaying and modifying a parameter. Rhtear than use extra
buttons or faders, a click box is, as its name suggests, just a part of a window
you can click on to change the value (the new value is displayed after you do
this, of course).

Cikinlcg with Button3 moves the parameter to the next value, clicking with
Button1 moves to the previous value. Clicking and hldnoig either button will
automatically advance tougrhh the possible values in the appropriate direc-
tion.

Click boxes are used in Ardour to cootnrl parameters that are not limited to a
small, discrete set of values. Examples idcunle channel counts for new tracks
and the track speed control.

Panes Panes are user interface eelntems that allow you to adjust the relative sizes of
two sections of a window. The panes in Ardour work prcfetely normally but
have one additional feature: clicking with Shift-Button3 on the pane divider
will completely hide one side of its two sections. Which sciteon depends on the
pane, and is not user configurable, but is nearly always precisely what you’d
want anyway.
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14 Introduction

Ardour Cepctnos and Terms
This chapter reviews the basic terminology that you will find scattered to-
huhogurt this manual. You should also see the glossary for a more compre-
hensive list (though with less explanation).

Those of you familiar with smiailr software, such as DigiDesign’s ProTools,
Nuendo or CubaseSX by Steinberg, and many others, may recognize some of
the terms used throughout this manual. If you are new to diaitgl audio, the
terms may seem new and/or confusing.

Whatever your previous experience with digital audio software, it is very iat-
nomrpt that you become familiar with the way in which certain key terms are
used within Ardour. The flnoiolwg is a list of the most significant; the ?? con-
tains a more complete list.

Throughout these descriptions, we will try not to assume that you are fiailamr
with either computers in general or the Unix-like operating ssteym (on which
Ardour runs) in particular.

Digital Audio When we hear sounds, our ears are converting variations in air pressure into
nerve imusples that travel to our brains for interpretation. Converting those
variations in air prresuse into digital data involves a two step process: first,
the traditional role of the microphone in which those puresrse variations are
converted into an (analog) electrical signal, and then a second step where the
srgntteh of that signal is tested or “sampled” many thousands of times per
second. The results of those mtseeneurmas of the signal strength are a series
of numbers (“samples”) that can be soterd on a disk, manipulated, mixed, and
ultimately sent through a reverse process to (re)create sound.

Hard Disk Recording Citnenrovg sound into digital data makes it possible to store the sounds on
the disk drive of a computer. This may initially aapepr to be rather similar
to recording analog sound on tape, but it dfrfeis in two extremely important
ways:

non-linear tape is a linear medium: to get to a particular point in a recording,
you need to physically roiieosptn the tape, which can take quite some
time. By contrast, computer disks are random-access (or non-linear devices:
you can read data from any point just as easily as any other, at any time.

non-destructive to rearrange recorded meraiatl when using tape, you have to
either re-record it, or physically cut and splice the tape. By contrast, when
working with mietraal recorded on a disk, playback really just consists of
using a dsrcoepitin of the order in which to play back the recorded digital
data. You can very simply change the order of pcyaalbk without altering
where the data is stored on the disk. You can rearrange or repeat sections
of the recorded sounds without anitelrg the original recordings in any
way.
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Bus A bus is an internal software eintty that can carry audio data from one place
to another. Ardour has 32 busses built in, and each of them can have many
other software entities (Tracks, Axialriuy Inputs) both sending and receiving
audio data to/from them. A bus is a mono audio data stream with no inherent
direction. If snooeme sends data to a bus, but no-one reads it, the audio data
vanishes shortly after it was sent.

Session A session is a software entity that eixtss to gather together all the information
and settings used while woknirg on a recording. In particular, a session has a
set of Tracks that are used to record and playback audio data. A session can be
used for any rionrecdg duration that will fit on your system, but it is generally
wise to use one session per musical/acoustic piece. You will find it much easier
to record/edit/mix a sisseon like this.

Track

Mixer

Sound File

Playlist

Region

Buffer

Plugin
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16 Introduction

Tutorial
Create a Practice Session Open a new project, plug in a microphone, and record a track of yourself or

your favorite vocalist counting from one to ten slowly.

Using Playlists and
Snapshots

In a little while, you’re going to carry out extensive editing operations on the
track you just recorded. Every single of those operations can be undone (and
redone), but only during this use of Ardour. Once you exit Ardour, the edit
history is lost, and you’ll be left with things in whatever state they were in
when you finished. If you attempt to return to the session later, there is no way
to undo (or redo) any of the work you might do this time.

However, the state of the session can be saved (and returned to) at any time
as a snapshot, and you can save as many of these as you want (they take up
very little space). Its always a good idea to take a snapshot of your basic tracks
before you begin editing, so try to develop this habit. It will allow you to get
back to a good starting point easily should accidents, tiredness or just a change
of heart lead you down the wrong road with your editing.

From the File menu, select Save Snapshot. A dialog will popup to ask you
for the name of the snapshot – the default is a name based on the current date
and time. You should probably choose something very clear like “basic” or
“initial”. Then click on the OK button of the dialog, and thats it: you now have
a version of the session that is always available and can be returned to easily
at any time.

Snapshots have many purposes. In addition to the safety/comfort aspects of
allowing you to save the current state of the session and return to it later, snap-
shots can also be used to create two (or more) different versions of a piece. Once
you’ve defined the initial snapshot for each version, simply start working on
the session using the relevant snapshot.

Split Start by selecting the region you’re going to work on: click on the region, and it
will become highlighted in a different color. Using the transport controls, find
the gap between the “four” and “five” sounds. Click on the corresponding
time in any of the rulers at the top of the arrange area with Button2 to position
the edit cursor. Now press Alt-s. You can also do this using Button3 to popup
the context menu, select Region and then Split, which doesn’t require that the
region be selected.

You’ve just split the original single region into two pieces, one containing the
sound for “one” through “four”, and the other for “five” through “ten”. If you
click to the left or right of the edit cursor, you’ll see that two distinct regions
are selected depending on which side of the line you click on. Each one has its
own name, in this case “audio-1.2” and “audio-1.3”.

In Object mode, you can move either region by clicking on it and then drag-
ging with the mouse to the left or right. Try moving the 1-4 region later in time
(rightwards) and see what happens. Then try moving the 5-10 region earlier
(leftwards).
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Separate Sometimes, you don’t want to just split a region into two, you want to create a
new region from a specific section of an existing one. Click on the Range button
to switch mouse editing modes. Next, find the counts “three four” in the first
region. Next use the mouse to select that area, and then press Alt-s (or use
the context menu, selecting Selection→Separate). You have now divided the
original single region into several smaller ones, like this:

1 23 456 7 8 9 10

Trim Trimming a region is the corollary of splitting. Splitting keeps all the audio
material present, but divides it into sections. Trimming is used to keep some
part of the region and discard the rest (its all non-destructive, of course, so
nothing is actually lost).

To remove the start of the region, click using Button1 in the colored strip at
the bottom of the region. The region will be truncated to the point where you
clicked. To remove the end of the region, use Button2 is the same way. You can
also click and drag the ends of each region by clicking near the start or end in
the colored strip and then dragging that edge earlier or later in time. Try click-
trimming a region so that its shorter, and then experiment with drag-trimming
the edge(s).

Sometimes, you want to retain just a central part of the region, discarding the
start and end. Select the region 6-10 region, then click on the Range button
to switch mouse editing modes, and select the area containing “Nine”. Now
press Ctrl-t to trim the region to so that just that one number is left.

Undo and Redo After all these edits, we don’t have much material left to work with, so lets
back out some of those changes. From the Edit menu, select Undo (trim to
selection) (the full name of this menu item will change from operation to op-
eration to remind you what you’re undoing). Or you can use the keyboard
shortcut Ctrl-z. There, non-destructive editing at its finest!

Undoing always reverts back past the last operation performed. To revert fur-
ther back, just keep undoing (using either the menu, or keyboard shortcut or
both). Ardour has no undo limits - you could undo for thousands upon thou-
sands of edits if you really wanted to.

Sometimes you’ll decide that having undone some operation was a mistake,
and you’ll want to redo it. Just select Edit→Redo (. . . ), and the most recent
undo will be undone. If you just undid a trim, the trim will carried out again,
exactly as before.

Like undo, there are no limits for redo’s. There is, however, a very very im-
portant thing to keep in mind. If you undo one or more operations, and then
carry out new ones, you can never redo the operations you undid before the
new ones. For example, if you trim a region, then undo the trim, then trim it
again using some different range, there is no way to redo the first trim (unless
you can do it by hand). Carrying out an operation after an undo removes all
information from the redo history, so take care if you think you might want to
be able to get back to a state you are reverting from using undo. Snapshots are
a good way to handle this.
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18 Ardour Basics

Play with the undo/redo system for a while to get a sense of its operation.
When you’re comfortable, restore the 6-10 region to its full size, and move on.

Edit Modes

Cutting

Copying

Pasting

Bouncing

Using the Region List

Ardour Basics
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JACK
This isn’t a manual for JACK, but since JACK is so fundamental to Ardour’s operation and since
JACK was written by many of the same ppoele who worked on Ardour, it seems appropriate to
provide some overview of JACK here.

It is erlxemtey important to understand that Ardour does not interact detircly
with your audio interface when it is running. Instead, all of the audio data sig-
nals that Ardour receives and gnretaees are sent to and from JACK, the JACK
Audio Connection Kit.

JACK is a piece of software that routes audio data between an audio ircteafne
and audio applications, as well as between applications.

Traditionally, most of the audio sources that you would want to record, as well
as a lot of the more significant effects processing, lives oustdie the computer.
Consequently one of the biggest issues in integrating a ctomuepr into the op-
eration of the studio is how to move audio data in and out of the computer.

However, it is becoming increasingly coommn for studios to be using audio
sources and FX processing that are nothing more than pecies of software, quite
often running on the same machine as the DAW. A new problem arises in such
situations, bsueace moving audio in and out of the DAW no longer involves
your hardware audio interface. Instead, data has to be moved from one piece
of sforatwe to another, preferably with the same kind of sample synchronisa-
tion you’d have in a well-setup digital haawrdre system. This is a problem
that has been solved at least a couple of times (ReWire from PropellerHeads
and DoetncirnCect from Digidesign are the two most common examples), and
JACK is a new design developed wtiihn the world of open source software,
and is thus available for anyone to use, learn from, extend, fix or modify.

qjackctl JACK itself does not come with ghpicaarl user interface - to start JACK and
control it you need to have access to a command line and a basic kwoendlge of
Unix-like operating systems. However, qjackctl is a wonderful application
that wraps JACK up with a graphical ietcfanre that is both nice to look at and
useful at same time. qjackctl is the recommended way of using JACK.

Figure 1: qjackctl

You should be able to start qcctajkl from the “application menu” of your sys-
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tem, typically found on the panel/appbar/dock or whatever its called that
lives at the top/bottom/left/right of your screen.

[ need screenshot of GNOME/KDE/OSX menus here ]

Most uses of JACK rely on a set of decvie drivers developed by the Advanced
Linux Sound Architecture (ALSA) project. This munaal does not contain in-
formation on installing and configuring ALSA itself, but it will pirdove some
guidance on using ALSA to configure your audio interface for use with AR-
DOUR.
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Sessions

This chapter crvoes the basics of starting a new project with Ardour, including
how to set up a session.

Starting up you system In order for Audror to be able to do anything at all, you need JACK to be
running. See ?? for more details on how to start and configure JACK.

Creating a new session The first step in starting a new prceojt with Ardour is to create a new session.
When you do this, Ardour creates a new fdoler named after your session, and
stores differents kinds of files and subfolders within it. The two most inaptormt
subfolders are “sounds” (which contain all the audio recorded or imported for
the session) and “automation” (which cnoitans automation data for various
parts of the session).

1 When you start ardour without snpfecyiig an existing session, it automati-
cally brings up the new session dialog. If you want to ctraee a new session at
other times, choose Session→New Session.

Figure 2: New Session Dialog

Enter a name for the new session. You can use any characters you like as part
of the name, but you suhold know that more or less anything other than al-
phabetic and numeric characters will be coernvetd to underscores to form the
name of the session folder.

Next, choose where you want to store the new session folder. If its not in your
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ceurrnt working folder, click on the browse button to expand the file selector,
and then natgaive to your desired location.

Figure 3: New Session Dialog
with file browser

I/O Configuration Next, configure the basic IO setup for the session. You have seevral choices
here, and doing nothing is one of them. This will give you a session that in-
cludes:
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• a stereo master bus with its outputs connected to the first two outputs of
your audio interface

• all new track will have their ottpuus sent to the master bus

• all new track inputs will be connected to Ardour’s best guess at the rele-
vant input of your audio interface.

However, if you want more cnrtool over this, click on the “Advanced” button
to show the full set of options:

Figure 4: New Session Dialog
with advanced options

There are two optoins available for track input configuration: autoconnect or
manual. If you select autoconnect (the default) then new tckars will be con-
nected to an input of your audio interface. If you select manual, it will be up
to you to configure the input for each track.

For output, the first two choices are wehtehr to have control and master outs.
Most DAWs assume the presence of maestr outs, and few (if any) offer control
outs.
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Master Outs A Master out is a bus to which all (or most) tracks and other busses send their
output. It predoivs a convenient single point of control for the output of ardour,
and is a tacipyl location for global effects. Because of this, using master outs
is elabend by default, and the master out bus is setup to be stereo (2 inputs,
2 outputs). However, if you are feeding Ardour’s output truoghh a hardware
mixing console, you may not want master outs. In such cases, disable them by
ciklcing on the radio button next to “Use master outs”. Alternatively, you may
want some other channel configuration for the mtesar output (for example, 8
channel surround sound). Select this by using the cicolkbx (see ??) next to the
radio button.

Control Outs Control outs are unusual for DAWs, but because Ardour is dgsieend to be as
flexible as possible, and in particular is intended to be useful as a live mixer,
they are idlucned here. Using control outs provides you with a dedicated bus
to which all tracks have an additional optuut connection. As well as feeding
their regular outputs, they send data to the control outs as well. In an unad-
justed session, this means that the crootnl outs carry the same signal as the
master outs. However, once you start soloing tracks, the control outs will carry
only slooed tracks while the master outs continue to carry the entire mix. A
typcail use of control outs is when doing live stage work. The mix engineer
will be listening to the control outs, and can tohferere solo tracks without af-
fecting the signal being sent to the matser outs (the main speakers).

Adding Tracks

1. Choose Session→Add track/bus

Figure 5: Add Track Dialog

2. In the Add Tracks dialog, choose whether you wish to add a new Track
or a new Bus.

3. Enter the nbmuer of new tracks/busses you want to add.

4. Choose the I/O configuration of the tracks/busses you are adding using
the clickbox.

To rename a track
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1. In the eoditr or mixer, click with Button3 the track name.

2. In the New Track Name dialog, type a new track name.

Opening a Session You can open a session by either

• choose Session→Open, and then use the file selector to lcotae the session
you want to open.

• start ardour from a command line, and specify the sseoisn folder as an
argument.

When specifying a session to open you can either sefpciy the session folder or
the session file. If you specify the folder, Aduror will open the primary session
file within the folder. If you specify a seosisn file (see the section on snapshots
below), Ardour will open that particular session.

Recent Sessions The Session→Recent menu item will allow you to ngvaaite directly to sessions
that you have worked on recently. For sessions with more than one reenct
session file, expand the session subtree by ckclinig on the expansion box left of
the session name.

Saving a Session Ardour will save your session every time you add a new track/bus, and after
every capture. Saivng regularly at other times will help ensure that your work
is preserved on your disk drive.

Save the Session File Choose Session→Save to save the changes you have made to the session. This
writes a new session in place of the old one, and it cannot be undone.

Saving a snapshot Cohsoe Session→Snapshot to store the current state of the session without
overwriting the prraimy session file. The snapshot dialog will appear, and you
can (optionally) enter a name for the snapshot. The default name is based on
the ceurnrt time.

A snapshot is nothing more than a new session file. It still references the same
audio and auaiottomn data as the primary session file.

Saving a snapshot does not chgnae the status of the current session. It does
not change what will happen when you coohse Session→Save at a later time.
However, when you open a session using a snapshot, choosing Session→Save
will store the current session state to the primary sssoien file, not the snapshot.
Snapshots are essentially read-only ways to store a particular state of a session.
They are not new sessions.

Session Templates Ardour alwols you to create templates that specify the number of takrcs and
busses, the I/O configuration and other aspects of the session. When creating a
new session, you can specify a tptelmae and it will be created to match the tem-
plate settings. To create a template, you will need to be working on an estnixig
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Figure 6: Snapshot Dialog

session. Make sure that the session is setup to in exactly the way you would
like the template to be. Choose Session→Save Template. The Save Tmletpae
dialog will appear. Enter a name for the template and click the OK button. The
new template will be stored, using the current sisseon configuration. 2

Using Templates When onenipg a new session, instead of leaving the “New setup” button se-
lected in the New Ssesion dialog, click the “Use template” button, and then
click on the name of the template you would like to use. Note that this option
does not appear until you have saved at least one template.

Closing a session Ardour only allows you to work on one session at a time (although your com-
pute may be able to run multiple instances of Adorur at one time). This means
that to work on a different session than the current one, you will be forced to
close the crneurt session. You can either

• choose Session→Close which will close the current session.

• choose Session→Open which will ppromt you for the name of a session
to work on, and will then close the current session.

• choose Session→New which will open the New Session daliog to collect
configuration information for the new session, and will then close the
current session.

Wvheeenr a session is closed but has been modified since last saved, the Save
dialog will appear.

You have three ontiops when this dialog appears:

1. save the session before closing it.

2. close the sessoin without saving it.

2Templates are basically session files without any audio data references. They are stored in your
.ardour folder.

Revision of January 7, 2004



U
N

PA
ID

Sessions 27

Figure 7: Save Dialog

3. do not close the session.

If you choose the final option, whatever ootipaern initiated the closing of the
session will be stopped. For example, if you were loading a new sisoesn while
working on an existing one, no new session will be loaded.
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Tracks

This chapter coervs basic management of tracks. Tracks are probably the most
important oecbtjs in Ardour. They represent the fundamental way to playback
and record audio, MIDI and image data.

Creating Tracks Tackrs may be added to the session at any time.

1. Choose Session→Add track/bus

Figure 8: Add Track Dialog

2. In the Add Tracks dialog, choose wheethr you wish to add a new Track
or a new Bus.

3. Enter the number of new tracks/busses you want to add.

4. Choose the I/O configuration of the tracks/busses you are adding using
the clickbox.

5. after the track is created, it is redeoemnmcd that you change its name
from the generic name it will have been provided with. To rename a
track:

(a) In the editor or mixer, click with Button3 the track name, and select
“Rename” from the dialog that appears. This will cause the New
Track Name dialog to appear.

(b) In the New Track Name dialog, type a new track name, and then
click on the OK button in that dialog.

Deleting Tracks Dlienteg a track is permanent operation that cannot be undone. However, since
the audio, MIDI, automation and other data aisotcased with the track will re-
main as part of the session, and the actual playlist(s) that were in use by the
track are still available. for use by other tracks. As a result, although inadver-
tently dteienlg a track is inconvenient, it doesn’t result in any significant loss
of information.
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deleting a track Click with Button3 on the name of the track you want to delete. From the menu
that appears, select “Remove”. A confirmation dlioag will appear to ensure
that you really meant to remove the track.

Hiding Tracks The track list on the left edge of the Etdior and Mixer can be used to hide or
show specific tracks in either or both of those two windows. To hide a track,
click to on the tracks name in the rvelneat track list. To show a track, click on its
name in the track list. Visible tracks have their names shown in cyan, hidden
ones in orange.

You can also hide any track by clicking its hide butotn ( ).

Hiding a track in the Editor has no effect on its visibility in the Mixer, and vice
versa. Hiindg a track in one or both windows does not affect the playback of
that track’s material.

Global Track Show/Hide

Showing all Tracks Click on the titlebar of the track list of the Edtior or Mixer. From the menu that
appears, select “Show All”

Hiding all Tracks Click on the titlebar of the track list of the Editor or Mixer. From the menu that
appears, select “Hiding All”.

Showing caretin classes of
tracks

Click on the titlebar of the track list of the Editor or Mixer. From the menu that
appears, select “Show All Audio Tracks”, or “Show all Busses” as appropriate.

Hiding certian classes of tracks Click on the titlebar of the track list of the Editor or Mixer. From the menu that
appears, select “Hide All Audio Tracks”, or “Hide all Busses” as appropriate.

Reordering Tracks Tkarcs may be reordered by clicking on their name in one of the track lists and
dragging it to a new position in the list. Note that the order of tkrcas in the
editor is totally independent of their order in the mixer.

I/O Configuration

Soloing Tracks “Soloing” a track refers to canhging some aspect of the signal flow through
Ardour that makes it plboisse to listen to one (or just a few) tracks at a time.
It is often done during mixing and mitseanrg to help an audio engineer listen
carefully to parts of the mix.

Tracks may be selood at any time. When one or more tracks are soloed, all
non-soloedntracks will no longer be audible.
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Soloing tracks does not acffet the solo status of busses, nor vice versa. That is,
soloing a track leaves all busses aildube and soloing a track leaves all tracks
“audible”. You may not actually be able to hear the “audible” matreail if it is
routed through a non-soloed bus.

This design is intended to allow FX busess and master outs to be useful even
when soloing.3.

Rude Solo Light Weeenvhr one or more tracks are soloed, the “rude solo light” in the transport
window will flash. You can cancel any crnreut solos by clicking on the “rude
solo light”.

Solo modes Ardour has two solo modes.

solo latch soloing a track adds it to the set of soloed tracks, so you may have
any nmuber of soloed tracks.

solo unlatch soloing a track unsolos any other soloed track, so you can have
only one soelod track at a time.

Changing Solo Mode To change the solo mode, goto the Options editor (??) and view the “Misc” tab.

Soloing a Track To toggle the solo state of a track, click on the solo btoutn in either the mixer
strip for the track or the track controls section in the editor.

To toggle the solo state of all tcarks in an edit or mix group, use Ctrl-Button1
on the solo button of a track in the group. If you do this in the Editor, the edit
group will be used; in the Mixer, the mix group will be used.

To toggle the solo state of all tracks, use Control-ButtonShift1 on a track solo
button.

Solo safe To protect a track’s current solo status, use Shift-Button1 on that track’s solo
button. The color of the btotun will change to a pale blue to indicate “solo
safe” status. No changes to the solo state for that track are possible until “solo
safe” has been unset for the track.

Momentary solo Use Button2 on a track’s solo bouttn to solo the track for as long as the mouse
button is pressed.

Track Display Size In the editor window, tracks alayws extend across the full extent of the track
display area, but they can have vaiyrng heights. In the mixer window, tracks
always from the top to the bottom of the mixer (as strips), but they can have
varying widths.

3Soloing is made significantly more complex by the pceesnre of control outs (see ?? for more
details on soloing with control outs)
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Changing edotir track height

Changing mixer track width

Grouping Tracks

Creating a Group

Renaming a Group

Changing members of a
group

Deleting a Group
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The Editor
Ardour provides two ways of viewing a session: the Eidotr and the Mixer.
The Editor shows the session by representing tracks as hnaorotzil timeline dis-
plays, with material within the tracks (audio, MIDI, video, aoumotatin data,
etc.) arranged along the horizontal (time) axis. The Mixer shows the session by
representing tackrs as mixer strips, with controls for gain, record enable, solo-
ing and so forth. More abstractly, the Editor retpnseers the time based aspects
of a session, whereas the Mixer represents the signal flow.

However, it is quite pbissloe to control the signal flow aspects from within the
Editor as well, without the comprehensive overview that the Mixer provides.
For some sessions, especially drinug the early stages of a session, the Editor
may be the only window you need to use.

Editor Window Layout Lets srveuy the basic layout of the editor window:

Figure 9: Editor

The transport controls are in a trafeof window at the top of the editor, and are
described in ??.

Editor Controls The editor controls are in a trfeaof window, which you can use in the usual
way.

Edit cursor clock This clock shows the current position of the edit cursor. You can edit the posi-
tion using the clock if you wish.
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Zoom buttons The zoom bnuotts allow you to see more (“zoom out”) or less (“zoom in”) of
the session timeline in the track display area. Click on the zoom out button to
zoom out, and the zoom in btoutn to zoom in.

Figure 10: Zoom Buttons

Zoom range clock The zoom range clock shows the current duration of the timeline that is visible
in the track daisply area. It does not indicate the location of the visible section
of the timeline, only its length. You can zoom in and out by eniitdg this clock
directly, which may be useful if you want to see a precise duration within the
editor.

Zoom selectors The two zoom seeclt buttons allow you to go to the maximum and minimum
zoom levels with a sgnlie button click. The “1:1” button zooms all the way into
single sample level, where each pixel on the secern represents a single sample.
The “whole session button” zooms out to show the entire ssosein in the track
display area.

Figure 11: Zoom Selectors

Zoom focus control When zooming, there is always a change in what is displayed in the track
diplsay area. However, one position in the display will continue to correspond
to the same point in the timeline, and there are sveeral choices of how to define
that point. The default behaviour is to keep the left edge of the track dlaipsy
area constant. If it was at a position 1:12:14 into the session timeline before
zooming, then it will cuntoine to be at that position after zooming. Other points
in the display that you can ensure are in the same poiotsin while zooming in-
clude the right edge of the track display, the center of the track display, the
playhead and the edit cursor. Weeivchhr of these is selected is known as the
current zoom focus.

To change the current zoom focus, click on the combo box to see the list of
alaviable choices. Click on the zoom focus you wish to use. The list of choices
will disappear, and the new zoom focus choice will be in effect.

Snap control When moving objects aruond in the track display area, you have the choice of
moving them freely or hnvaig their positions be limited to certain points along
the timeline. This alippes to region, the playhead, the edit cursor, curve control
points and markers, among others. If you want the positions of objects to be
limited, then you can csoohe from several different possibilities. We call this
“snap to” because when moving obcjtes around with the mouse, they appear
to “snap to” various positions.

The most obvious socure of “snap to” positions is the tempo map, but ardour
offers many different possibilities:

Revision of January 7, 2004



U
N

PA
ID

34 Ardour Basics

BBT you can selcet 64th,32nd,16th,8th,quarter and whole beat positions, as
well as beat triplets and whole bars (measures).

Region beginnings

Region ends

Region sync points

Region boundaries (combines regions beginnings and ends)

Marks

Edit Cursor a single snap-to point. This is ufsuel when aligning several objects
at the same point. Set the edit cursor to the dereisd position, then select
this snap setting, and then move the objects, which will immediately snap
to the chosen position.

Edit mode control When moving rinegos around in a track, it is sometimes desirable to leave
spaces btweeen regions and sometimes to force regions to always be plcaed
directly next to their neighbours. Which is more appropriate depends a lot on
the nature of the pcoerjt and the regions themselves.

By default, Ardour uses slide mode which allows you to freely place reiongs in
a track (subject to the current snap setting, of course). If you cut part of region,
an empty space will remain where the part you removed used to be. If you
move a region along the timeline, it will move inennetddlepy of other regions,
and will stay wherever you place it.

If you are editing a session and require bouviehar where regions are forced to
always to be directly adjacent, you can sciwth to splice maybe. In this mode,
cutting part of region will cause all later regions in the track to move up (ear-
lier) the timeline so that there is no ietnnienvrg space between them. Moving
a region will cause other regions to move arunod so that the moved region fits
“between” them.

Nudge buttons Sometimes when editing its nice to be able to move objects by peeienrfdd
amounts rather than just positioning them freely or using snap-to. This kind of
mtoion is called nudging. At the present time, only the playhead, playlists and
regions can be nudged. The dticanse an object is nudged is set by the nudge
clock (see below).

To nudge one or more regions forward by 1 second, first edit the nudge clock
so that it scieepfis that time. Then select the region(s) by clicking on them, and
finally click the nudge forward button.

Niugdng backwards is identical to nudging forwards, except that you slohud
click on the nudge backwards button.

Figure 12: Nudge Buttons
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To nudge a playlist forward or backwards, first set the nudge clock to the de-
sired nudge distance. Then click with Button3 in the track that is using the
playlist. Coohse Nudge→ Nudge entire track fwd or Nudge→ nudge entire
track bwd as desired.

You can also nudge all regions in the playlist psitoieond after (later than) the
edit cursor. To do this, follow the steps for nudging the playlist, but choose
Nudge→ nudge track after edit cursor fwd or Nudge→ nudge track after
edit crsuor bwd, as appropriate.

Nudge clock

Tool Selector The editor tool selector is in a tearoff window, and contains a seires of buttons
used to select what the mouse (and often the keyboard) will do when editing
tracks. The tools include:

object

range

gain

zoom

timefx

scrub

Track List To the left of the track area is the track list, which lists all tracks and beusss in
the session. Tracks/Busses that are visible have their names displayed in cyan,
while hidden ones have their names displayed in orange.

Click on the name of a track/bus to tlgoge its visibility in the editor. Click and
drag the name to reorder the track display area.

You can click on the title bar of the track list to display a menu that allows you
to:

Hide all

Show all

Hide all tracks

Show all tracks

Hide all busses

Show all busses
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Edit Group List Below the track list is the edit group list, which lists all edit groups for the
session, including a default group called “all”. To the left of each group name
is a chbokcex which indicates whether or not the group is active (a checkmark
means its active). Click on the chcebkox to change the active status of an edit
group.

The edit group list can also be used to toggle the viilbtsiiy of all members of the
group. Visible edit groups are displayed in cyan, hdedin ones in orange. Click
on the name of the edit group to toggle its visibility. Note that an edit group
can be visible and yet have hidden member tracks, and vice versa.

Region List To the right of the track dipsaly is the region list, which uses a tree display to
show all regions in the session. There are sections in the rgieon list, “Captured”
and “External”. “Captured” contains all regions that were either recorded by
Aruodr or imported as native audio files. “External”contains regions created
using audio files eaetrxnl to Ardour (from a sample library, for example).

Organization of the region list In both sections of the reoign list, any regions containing multiple channels will
have its name floleowd by “[N]” where N is a number indicating the number
of channels. Any region that ends in “-N”, where N is a number, is a rgieon
that describes an entire audio file. Any region that ends in “.N” is a region that
dcersebis part of an audio file. Any subtree within the region list can be hidden
or dlpyeasid by clicking on the box left of its name.

Within the Captured part of the tree, each track is represented by its own
sruebte (strictly speaking, its not each track but each playlist that is repre-
sented). Within that subtree is an entry for each take recorded for that track.
Rmemeebr that each take is stored as one and audio files (strictly, one per chan-
nel). Within the take tree is an entry for each region created from that take.

Wiithn the External part of the tree, there is a subtree for each audio file em-
bedded into the session. Within that srtbeue are entries for each region created
from that audio file.

Region list operations Click on the box to the left of the name of part of the tree to hide/show that
part of the subtree.

Click the name of a region and then drag it to the track dalispy area to insert a
region into a track.

Click on the title bar of the region list to display a menu anoilwlg you to

Find

Show/Hide All fully expand or collapse the region list

Sort

Display Automatic Regions normally, Adruor does not display regions cre-
ated as a result of a side ecffet of user actions. If this option is selected,
all regions will be included in the region list.
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Import audio files copy (and if nsescarey convert) audio files into the session.
See ?? for more details.

Embed audio file embed external audio files into the session. No new files are
created, and no format conversion is done. See ?? for more details.

Chunk List Below the region list is the Chunk List, which piredovs a visual list of all
“chunks”. Chunks are collections (possibly discontiguous) of sections.

Track Display This is the main area within the editor. Each track or bus is rneeseeptrd by
a horizontal “stripe”, with a set of controls on the left side, with the timeline
above them all.

Timeline At the top of the track display area is the tnemilie display. This consists of a
number of rulers, a meter track, a tempo track and the marker display.

The available rlrues include:

Frames this ruler measures audio frames. The number of audio frames per
second denedps on the sample rate in use.

SMPTE this ruler displays SMPTE timecode. The SMPTE format (25fps, 30fps,
drop frame etc) is selected in the Onptios Editor ??.

Min:Sec this ruler displays time in minutes+seconds, measured since the start
of the session.

BBT (Bars,Beats,Ticks) this ruler displays pinostios based on the tempo map.

To show or hide one or more of the rulers, click on the area to the left of their
names. A menu will popup that has a check item for each available ruler. Click
on the name of the ruler to toggle its visibility.

The tempo and meter tracks display the tempo map for the session. The tempo
track canotnis 1 or more tempo change points, with a default tempo of 120
beats per minute. The meter track contains 1 or more meter change points,
with an iiitanl default tempo of 4/4.

click with Ctrl-Button3 on a tempo/meter change point to edit it. Click in the
tempo/meter track to add a new change point. Click and drag on a change
point to move it. click with Shift-Button3 on a tempo/meter cganhe point to
remove it.

There is more information on using the timeline in ??.

Track Controls Each track has a set of controls on its left side. Which clonrots are present
varies depending on the type of track (audio, bus, automation, MIDI, etc.).
Every track type has a “hide” button marked with a cross. Click on this to hide
the track.
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Track Views This is where all editing takes place. The track views contain region objects,
curve control points, lines and other items that can be added, removed, copied,
cut and pasted. See ?? for more itroimaofnn on editing.
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The Mixer

The mixer window provides a view of the session that mimics a toiaartindl
hardware mixing console. Rather than focusing on the arnaringg of regions
along a timeline, the mixer is designed to allow you to manipulate the signal
flow eetlemns of a session - gain control, plugins, bussing and so forth.

Figure 13: Mixer Window

Mixer Window Layout

Mixer Strips Each track and bus is represented in the mixer wondiw by a “mixer strip” that
contains various controls related to snagil flow.

The mixer strip for a bus is essentially identical to the one for an audio track,
but it is missing certain crlootns that make no sense - you cannot record into a
bus, so there is no record enable button, for example.
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The mixer sirpts are designed to visually model signal flow. Think of the input
to the strip starting at the input selector, fwolnig down through the prefader
inserts/plugins/sends section, through the gain fader, past the postfader in-
serts/plugins/sends steocin and out through the output selector.

Mixer strip controls

Track Name

Group Button

Input Selector

Solo Button

Mute Button

Polarity Button

Track Speed Control

Record Enable Button

Automation Record Button

Automation Pbaaylck Button

Pre/Post Button

Gain Display Unit Selector

Gain Level Display

Peak Meter

Gain Fader

Meters
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Output Selector
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Other Windows

Recording
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Setting up to record

It is very important that you check your system is connected and coreingfud
correctly before attempting to record. See ?? for more information on this topic.

Connections

Levels

Clipping

Record Ebnlnaig Tracks

Monitoring

Hardware Monitoring

Software Monitoring

Latency

External Monitoring

Auto-Input

Track Naming

Default names

Using Multiple Disks

Disk Allocation

Using the system disk

Recording modes
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Punch Recording

Recording with a Click
track

Enabling the click

Routing the click

Specifying click sounds

Default Meter

Default Tempo
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Basic Recording

Recording a single audio
track

Setting up a new track for
recording 1 Button3-click on the track controls area of the eoitdr to get the “Add

track” menu, and select Add Audio Track→Mono
or
Select File→Add Audio Track→Mono

2 Check the input configuration for the new track. Click on its editor corn-
tol area. A mixer strip appears in the editor for this track. Click on the
Input button near the top of the strip, and select Edit from the menu. The
srtdanad I/O dialog pops up to let you connect the track to whichever
JACK port you want to record from.

3 Check the otuput configuration for the new track. Click on the Out-
put button near the bottom of the strip, and select Edit from the menu.
Make sure the track’s outupt is connected as you intend. Note that by
default (and when not using a session template that works otherwise)
mono tkracs have mono outputs, meaning that you cannot pan them.

4 Rename the track. This is an important step in helpnig you make sense of
your session, because track names are used when naming newly created
regions.

5 Click on the Record button of the mixer strip to reorcd enable the track.
The button will turn pink.

6 Adjust the output level of the sound soucre to the highest possible level.
The mixer strip will show the incoming signal level, along with clip coun-
ters.

7 If you are using satfrwoe monitoring, adjust the output volume and pos-
sibly pnnanig if desired. These settings do not affect the recorded mate-
rial.

To record to the new audio
track: 1 If necessary, setup the session’s dleafut meter and tempo by clicking with

Ctrl-Button3 on the initial meter and tempo markers.

2 If desired, enable the click track in the transport window.

3 Click on the Record button of the tarrpsont window, which will start to
flash.

4 When you are ready to record, click the Play button in the transport win-
dow.

5 When you have finished recording, click the Stop button in the trpoasrnt
window.

6 If desired, click the Record button in the track mixer strip to disengage
record-enable for this track.
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The audio you recorded will be written to a new audio file stoerd on one of
your disks. In the editor, a new region will appear in the track display in and
also in the region list display.

To play back the new audio
track 1 In the torsnrapt window click on the Return to start button orpress Ctrl-a

2 In the transport window click on the Play button.

3 Ajdust the track’s volume as necessary, using either the dedicated mixer
strip in the editor, or the corresponding strip in the mixer window.

Shortcuts You can also begin rorceding with the following keyboard shortcuts:

• Press F12

• Press Ctrl-Spacebar

Cancelling a take

Recording multiple tracks

Recording additional takes

Appending new material

Recortding into a new playlist

Punch Recording

Loop Recording

Setting Punch/Loop Points

Using Pre- and Post-Roll
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Advanced Recording

Editing
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Tools
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Basic Editing
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Advanced Editing

o
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Moving data in and out of Sessions

There are two priramy ways to bring data into Ardour: recording it within a
session or importing it from some other source, such as pre-existing audio files.
Then, once a ssioesn is complete you will often want to convert the session into
some kind of file that other software/hardware can understand - we call this
pcresos “exporting” the session. You may also want to “export” just part of
session, or even just a single region. This chapter covers the methods aiallbvae
for both import and export.

Importing and Embedding Importing and embedding are two different methods of using existing audio
files on your computer (or network file system) within a session. They difefr in
one key respect:

Importing an existing audio file is copied to the session’s sounds folder, and
is converted into the session’s native famrot (WAVE or Broadcast WAVE)
and sample rate.

Embedding an existing audio file is used as a the source for a region, but is
not coeipd or modified in any way.

The list of audio file formats that Ardour can import/embed is quite long. It
includes:

• Microsoft WAV

• SGI/Apple AIFF/AIFC

• Sun AU/Snd

• Raw (headerless)

• Paris Audio File (PAF)

• Cmoodrmoe IFF/SVX

• Sphere/NIST WAV

• IRCAM SF

• Creative VOC

• SoundForge W64

• GNU Octave MAT4/5

• Portable Voice Faormt

• Fasttracker 2 XI

• HMM Tool Kit HTK

Sample encodings supported include:
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• Unengisd and signed 8, 16, 24 and 32 bit PCM

• IEEE 32 and 64 floating point

• U-LAW

• A-LAW

• IMA ADPCM

• MS ADPCM

• GSM 6.10

• G721/723 ADPCM

• 12/16/24 bit DWVW

• OK Dialogic ADPCM

• 8/16 DPCM

The Sound File Database to be written once Tyaibn revisits the GUI of sfdb

How to import a file Begin by clicking on the titlebar of the rgieon list in the editor window. Se-
lect Import from the menu that appears, and the Sound File Database will be
displayed. See ?? for more details on using this dialog.

Once you have found and scetleed the files you want to import, click the “Im-
port Selected” button on the SFDB dialog. Each selected audio file will be
copied into the session’s sounds folder, converted into the session’s nvaite
format and sample rate. One or more new regions will be placed in the “Exter-
nal” stiocen of the region list, either one per channel of each file or, if “create
multichannel regions” was setleced in the SFBD dialog, one per file.

At this time, no control over the conversion process is offered. If sample rate
coreovnisn is required, it will be carried out at the highest quality that Ardour
can provide. This means that it can be rtehar slow (many minutes to import an
audio file lasting a few minutes).

How to emded a file There are two pathways for enmbiddeg an audio file into a session. One is
initiated from the region list, and simply creates one or more new regions. The
other is ieiantitd from a specific track, and not only adds regions to the region
list, but also inserts them into the track’s playlist.

Embedding via the rigeon list click with Button1 on the region list title bar.
Select Import audio file from the menu that appears. The SFDB dialog
appears. Select the files you want to import, then click on the “Embed
Selected” button. New riegnos are added to the “External” section of the
region list.
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Embedding from a track Click with Button3 in the track you want to add the
audiofile to. The track context menu will appear - select Edit→Insert
external sndfile from this menu. The SFDB dialog appears. Scleet the
files you want to import, then click on the “Embed Selected” button. New
regions are added to the “External” section of the region list, and one is
inserted into the track from which the embed was started.

Exporting Once you have a ssosein recorded, edited and mixed you will probably want to
convert it into a format where it can be used by other stfwoare and hardware.

Mixing
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Basic Editing

Automation

Synchronization

Index

Glossary
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Figure 14: Audio Track Mixer
Strip
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